00:50:52  * bradleymeckquit (Quit: bradleymeck)
01:05:15  <trungl-bot>Tree closed by buildbot@chromium.org: Tree is closed (Automatic: "bot_update" on http://build.chromium.org/p/client.v8.fyi/builders/Auto-roll%20-%20v8rel/builds/51162 "Auto-roll - v8rel" from None: )
01:08:16  <trungl-bot>Tree opened by buildbot@chromium.org: Tree is open (Automatic: Boa sorte!)
02:42:16  * xiinotulpjoined
02:43:19  * xiinotulpquit (Max SendQ exceeded)
02:43:45  * xiinotulpjoined
02:43:53  * plutoniixquit (Ping timeout: 244 seconds)
02:45:41  * xiinotulpchanged nick to plutoniix
03:03:29  * plutoniixquit (Remote host closed the connection)
03:27:37  * plutoniixjoined
04:42:49  <koldbrutality>I found 2 major bugs for x32 abi with git bisect. I am looking for a third one.
05:13:47  * Tweth-V-PDSjoined
05:14:48  * Tweth-U-PDSquit (Ping timeout: 260 seconds)
08:45:59  * xaxxonquit (Quit: Leaving)
10:01:35  * j0hnsm1thjoined
10:48:57  * olalondequit (Quit: Connection closed for inactivity)
12:46:25  * plutoniixquit (Ping timeout: 260 seconds)
13:02:37  * Cube8joined
13:14:06  * plutoniixjoined
13:14:09  * plutoniixquit (Max SendQ exceeded)
13:16:56  * plutoniixjoined
13:39:12  * bradleymeckjoined
13:43:29  * bradleymeckquit (Client Quit)
14:03:50  * jwolfequit (Ping timeout: 256 seconds)
14:17:33  * jwolfejoined
16:24:18  * RT|Chatzillaquit (Quit: ChatZilla 0.9.86.1 [Firefox 2.0.0.22pre/2010030309])
20:00:27  * j0hnsm1thquit (Remote host closed the connection)
20:04:27  * Cube8quit (Quit: Leaving)
20:55:58  * xaxxonjoined
20:56:31  <xaxxon>anyone know why I can't seem to get a named property SETTER callback called? even when I say my_object.foo = 5, it calls my getter callback
20:57:51  <xaxxon>I've tried both the "new way" and the "old way"
20:57:59  <xaxxon>and everything I do calls the getter
21:04:14  <xaxxon>i just added a delete callback and it doesn't call that either.. just calls the getter
21:14:29  <xaxxon>delete p.foo calls nothing.. my delete callback doesn't get called, neither does getter
21:44:20  * olalondejoined
21:48:40  <xaxxon>this is making me so sad :(
21:48:55  <xaxxon>this seems like it should be so trivial
21:49:12  <xaxxon>olalonde, any experience with setting up named property handlers?
21:49:30  <xaxxon>I can't seem to have anything but my getter called. setter and deleter are being ignored
22:18:16  <xaxxon>maybe something about my object returning false from HolderIsReceiverOrHiddenPrototype ?
22:20:53  * xaxxonquit (Quit: This computer has gone to sleep)
22:21:22  * xaxxonjoined
22:24:43  * olalondepart
22:24:55  <xaxxon>I'm wondering if I'm somehow setting up a weird prototype chain or something.. but at this point I dont' really know what's going on :(
22:46:58  <xaxxon>ok.. so it's getting an attribute of "DONT_ENUM".. whatever that means
22:51:06  <xaxxon>I don't see this attribute type: if (maybe_attributes.FromJust() == ABSENT) break;... what is ABSENT
22:51:40  <xaxxon>but whatever I have is not absent, so it sets found = false.. which is weird. if it's not absent (meaning it's present) then it's not found
22:51:44  <xaxxon>so it's present, but not found?
22:55:15  <xaxxon>then it goes into AddDataProperty and I seem to get lost
22:55:57  <xaxxon>maybe I just need to implement another callback
22:56:03  <xaxxon>play some guess and check
23:01:16  <xaxxon>I added a query callback and that gets called now instead of getter, like I saw in the v8 source
23:02:12  <xaxxon>but I don't really understand if/how changing what this sendds back chagnes things
23:25:21  * RT|Chatzillajoined
23:48:42  * trungl-botquit (Ping timeout: 258 seconds)