00:53:21  * node-ghjoined
00:53:21  * node-ghpart
01:04:00  * node-ghjoined
01:04:01  * node-ghpart
01:24:13  <thealphanerd>jbergstroem you around?
01:27:01  <jbergstroem>yes sir
01:27:11  <jbergstroem>thealphanerd: ^
01:27:16  <thealphanerd> so I got caching the intl stuff working on CI
01:27:22  <jbergstroem>sweet
01:27:26  <thealphanerd>but wanted to check with you about a hack I had to do
01:27:32  <thealphanerd>I was getting hash mismatch's sometimes :(
01:27:41  <thealphanerd>(mostly when switching between versions of node)
01:28:22  <jbergstroem>wow
01:28:26  <jbergstroem>that's unexpected
01:28:48  <thealphanerd>so I'm now doing essentially: ./configure $CONFIG_OPTIONS || (rm -rf ${HOME}/node-icu && mkdir -p .. $$ ./configure $CONFIG_OPTIONS)
01:28:59  <thealphanerd>there were two different hashes I was getting depending when I was downloading it
01:29:41  <thealphanerd>so I wanted to check that it wasn't a problem that A) I was deleting stuffi n the home directory in my scripts. B) the hash mismatches are not a serious problem
01:30:01  <thealphanerd>example of the sha mismatch https://ci.nodejs.org/job/thealphanerd-smoker/148/nodes=debian8-64/console
01:41:32  <jbergstroem>two different hashes is concerning imo
01:41:40  <jbergstroem>should be fixed upstream
01:41:44  <jbergstroem>could be haxxored or whatever
01:43:08  <jbergstroem>is this sourceforge injecting stuff again?
01:45:20  <thealphanerd>no idea. But I'll bring it up to srloomis
01:46:38  <thealphanerd>jbergstroem it could be something on the system though. Because the hash would have had to match for the original install...
01:46:59  <jbergstroem>the hash should never ever change though
01:49:14  <thealphanerd>OH WAIT
01:49:14  <thealphanerd>https://ci.nodejs.org/job/thealphanerd-smoker/nodes=debian8-64/147/console
01:49:16  <thealphanerd>ha
01:49:26  <thealphanerd>the file was not finished downloading the time before
01:49:38  <thealphanerd>I'm the problem :D
01:50:57  <jbergstroem>phew
01:52:31  <thealphanerd>so I could probably change that line back now
02:01:27  <jbergstroem>yes i don't think removing the directory is hte way to go here
02:01:36  <thealphanerd>got rid of it
02:01:43  <thealphanerd>I shouldn't hit that edge case again anyways
02:06:44  <jbergstroem>good
02:07:06  <jbergstroem>i actually have a branch somewhere that improves on that download stuff
02:07:16  <jbergstroem>removes all python stuff and uses wget/curl
02:07:33  <jbergstroem>the refactor grew a bit bigger than I expected though
05:26:35  * ofrobotsjoined
05:53:54  * ofrobotsquit (Quit: My Mac has gone to sleep. ZZZzzz…)
05:56:15  * rmgquit (Remote host closed the connection)
07:55:33  * jbergstroemquit (Quit: bye)
07:56:08  * jbergstroemjoined
12:03:22  <joaocgreis>azure win2008/12 machine will be offline for a while, I'm fixing VS there
12:04:17  <joaocgreis>Windows SDK update makes Visual Studio use the wrong SDK, I'm fixing it
12:19:01  * ofrobotsjoined
13:00:17  * node-ghjoined
13:00:18  * node-ghpart
13:41:24  * ofrobotsquit (Quit: My Mac has gone to sleep. ZZZzzz…)
13:57:37  * chorrelljoined
14:14:08  * ofrobotsjoined
14:19:25  * Fishrock123joined
14:29:16  * chorrellquit (Quit: Textual IRC Client: www.textualapp.com)
14:56:30  * ofrobotsquit (Quit: My Mac has gone to sleep. ZZZzzz…)
15:00:14  * rmgjoined
15:05:16  * rmgquit (Ping timeout: 264 seconds)
15:14:16  * rmgjoined
16:52:00  * ofrobotsjoined
16:59:11  * ofrobotsquit (Quit: My Mac has gone to sleep. ZZZzzz…)
17:07:30  * phillipjquit (Ping timeout: 268 seconds)
17:07:33  * orangemochaquit (Ping timeout: 268 seconds)
17:07:38  * jbergstroemquit (Ping timeout: 268 seconds)
17:07:50  * ofrobotsjoined
17:07:59  * jbergstroemjoined
17:17:39  * orangemochajoined
17:19:17  * phillipjjoined
17:48:00  * node-ghjoined
17:48:00  * node-ghpart
17:54:42  <michael___>I assume no build meeting today as there is no issue ?
17:57:28  * nuizzyjoined
18:02:39  * chorrelljoined
18:20:21  * Fishrock123quit (Remote host closed the connection)
18:27:34  * evanlucasquit (Read error: Connection reset by peer)
18:28:28  * evanlucasjoined
19:11:59  * Fishrock123joined
19:27:34  <jbergstroem>hm thought it was next?
19:33:25  <jbergstroem>either way
19:33:32  <jbergstroem>no issue usually means no meeting
19:36:12  * chorrellquit (Quit: My Mac has gone to sleep. ZZZzzz…)
19:47:30  * chorrelljoined
19:53:34  * chorrellquit (Quit: My Mac has gone to sleep. ZZZzzz…)
19:54:18  * chorrelljoined
20:08:02  * node-ghjoined
20:08:03  * node-ghpart
20:09:16  * chorrellquit (Quit: My Mac has gone to sleep. ZZZzzz…)
20:10:32  * chorrelljoined
20:20:14  * chorrellquit (Quit: My Mac has gone to sleep. ZZZzzz…)
20:21:43  * ofrobotsquit (Quit: My Mac has gone to sleep. ZZZzzz…)
20:27:03  * chorrelljoined
20:33:00  * evanluca_joined
20:36:03  * evanlucasquit (Ping timeout: 244 seconds)
20:38:08  * chorrellquit (Quit: My Mac has gone to sleep. ZZZzzz…)
20:55:10  * chorrelljoined
20:59:44  * chorrellquit (Client Quit)
21:27:37  * evanluca_quit (Quit: Textual IRC Client: www.textualapp.com)
21:47:14  * evanluca_joined
21:48:34  * evanluca_part
22:12:29  * ofrobotsjoined
22:12:56  <jbergstroem>getting this on a debian8 slave i'm trying to set up. not a big debian user, anyone run into udev issues before? https://gist.github.com/jbergstroem/9f77dbb83152d39f4d1e3d45d6d55374
22:17:48  <jbergstroem><3 systemd
22:17:49  <jbergstroem>i just love it
22:18:15  <jbergstroem>one second i'm debugging udev (which i already dislike) and now i'm debugging some weird issue reading the journal of some other daemon not working
22:18:20  <jbergstroem></rant> but what the fuck
22:31:07  <jbergstroem>the problem seems to be twofold: 1. kernel is custom from joyent which makes some systemd units fail (dgram) 2. the udev-mountfs operation never completes which seems to be because joyent again mounts the fs though kernel boot but debian8 doesn't understand the fstype zfs so it fails.
22:32:58  <jbergstroem>So when the dpkg-scripts run as part of updating udev isn't properly started
22:37:12  * node-ghjoined
22:37:12  * node-ghpart
22:38:42  <jbergstroem>problem solved! switched to digitalocean
22:55:02  * jenkins-monitorquit (Remote host closed the connection)
22:55:11  * jenkins-monitorjoined
23:18:59  <jbergstroem>anyone around? just want to verify jenkins acl
23:26:14  * nuizzyquit (Quit: nuizzy)
23:29:08  * Fishrock123quit (Remote host closed the connection)
23:34:50  * ofrobotsquit (Quit: My Mac has gone to sleep. ZZZzzz…)