02:40:55  <SinisterRectus>hypothetical situation: websocket-codec depends on base64@2.0.0. what would happen if i tried to install a package that depended on, for example, base64@1.0.0?
02:43:08  <SinisterRectus>actual situation: coro-websocket is a dependecy of mine, so base64 ends up being included. i want to use base64 in my project, but i don't know whether it is proper form to just require it and assume that it is there because my project depends on coro-websocket, or should i explicitly add base64 to my dependencies, and if the latter, how can i be sure there won't be a version conflict
05:11:40  * DarkGodquit (Ping timeout: 255 seconds)
07:18:29  * rendarjoined
11:28:00  * DarkGodjoined
12:42:09  * Andolsjoined
12:53:10  * Andolsquit
14:48:26  * Andolsjoined
16:44:16  * dobsonquit (Quit: Leaving)
16:46:25  * SinisterRectusquit (Quit: Leaving)
16:47:29  * dobsonjoined
17:03:54  * SinisterRectusjoined
19:16:05  * rendarquit (Ping timeout: 240 seconds)
19:42:18  * rendarjoined
19:42:39  * rendarquit (Client Quit)
21:40:57  * squeek502_quit (Ping timeout: 240 seconds)
22:18:46  * Andolsquit
23:31:16  * squeek502joined